Visit our COVID-19 site for latest information regarding how we can support you. For up to date information about the pandemic visit www.sacoronavirus.co.za.

bs-regular
bs-extra-light
bs-light
bs-light
bs-cond-light-webfont
bs-medium
bs-bold
bs-black

Community


Share knowledge. Ask questions. Find answers.

Community

A one-stop forum for all your banking questions

Accounts not visible on Banking App Dashboard(Android) - worked previously

Solved
Reply
9 REPLIES 9
sramburrun
Occasional Contributor
Worked for me ๐Ÿ’ฏ Thank you for sharing ๐Ÿ™๐Ÿผ
FanaM1
Community Coordinator

Hi @Smzungu.

 

Thank you for reaching out.

 

To view your accounts on your banking app. 

 

Please follow the steps below:

  • After logging in
  • Click on more
  • Click Switch Dashboards

Check how many dashboards you have, and check in all of them if your accounts are not appearing.

 

Alternatively, you can reach us by calling 0860 123 000 and selecting options 3 and 4, or you can email us at [email protected].

 

Please let me know if this solution helps.

 

Regards

Fana.

Standard Bank Team.

Chrismari1208
New Member

Good day

 

I have tried the click menu as well but nothinig happens still blank and then within a minute ity tells me standard bank have stopped working and go out.........

 

Cant do anything.... Really annoying.

IRISC
New Contributor
Tried this, got to the step to add a profile and then which country I bank in, tried to step back, no profile created. Tried again, then it asked for my card number and pin, tried that and it says that is linked already. So frustrated
GTMarewo
Occasional Visitor

The following answer from a previous post gave me a working solution.

 

  • Login to App
  • Click More menu button(bottom right)
  • Then "add new profile"
  • "My Personal Dashboard" will be created(Don't do anything further, go back to home screen)
  • Click More button again "My Personal Dashboard" should have a blue circle next to it to show it is active
  • While this dashboard is active in the More menu scroll to Settings -- In the Dashboards category select your old dashboard("Banking Dashboard") and at the bottom delete and unlink
  • Now you can add your Banking Dashboard profile with the steps mentioned above and continue with linking card etc.( You will have 2 "My Personal Dashboard" profiles. Delete unused one and Rename the working one to whatever eg. Banking Dashboard) 

Basically, active the working dashboard if any then delete the one which is not working.

 

Regards.

 

Gerald

Jesussaves
Occasional Visitor
I am currently experiencing the same thing. Tried to follow the steps and the app won't let me reset my card. Says that the card already exists. What's happening. Should I delete the app and completely start over from scratch? I'm not happy with this app right now. Note. I'm using a Huawei p20
LesleyH
Solution
New Contributor

FYI

 

Spoke to tech support at Standard Bank. The solution is to delete your old dashboard, but first you have to create another dashboard(if don't have one already).

While the other dashboard is active then you are allowed to delete the "problem dashboard" (can't delete an active dashboard). Then simply add your Banking Dashboard again.

 

Steps followed:

 

  • Login to App
  • Click More menu button(bottom right)
  • Then "add new profile"
  • "My Personal Dashboard" will be created(Don't do anything further, go back to home screen)
  • Click More button again "My Personal Dashboard" should have a blue circle next to it to show it is active
  • While this dashboard is active in the More menu scroll to Settings -- In the Dashboards category select your old dashboard("Banking Dashboard") and at the bottom delete and unlink
  • Now you can add your Banking Dashboard profile with the steps mentioned above and continue with linking card etc.( You will have 2 "My Personal Dashboard" profiles. Delete unused one and Rename the working one to whatever eg. Banking Dashboard) 

 

Hope this helps others out there. Cheers.

Punkyn
Visitor
Same thing is happening to me. I'm also using a Huawei phone (P9 lite).
LaraLolla
Visitor
My accounts are not showing i just get a reload sign but nothing happens. Is anyone else experiencing this?
LesleyH
New Contributor

Hi 

 

Could someone please assist. I have an Android phone(P8 lite). I've been using the banking app without failure for a couple years now. The problem I have experienced recently is that my accounts aren't visible on my dashboard(only displays "add account"). I have checked the following:

 

  • Internet banking works fine.
  • Cards are still linked
  • Phone is linked in app
  • Check balance peek, works fine! ???
  • Once logged in can still access my beneficiaries, settings etc.
  • My device name doesn't have special charaters (solution posted for IOS device)

I tried to figure out what has changed on my device... the only thing that comes to mind is that I changed the default mobile data sim setting i.e. from sim 1 to 2 (dual sim setup). I changed this setting as before, but this has no effect on the App.

 

Thanks.

 

 

Thanks.

 

Go to the solution >